Author Topic: Edit shortcuts stopped working !  (Read 3788 times)

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 12911
    • Travis build status
Re: Edit shortcuts stopped working !
« Reply #30 on: April 19, 2020, 02:21:56 pm »
But this code is exactly the same as the one used for the stc sample. Is it working there?

It could be quite helpful if you can get us the steps to setup a machine which breaks it. There is some problem and it is probably best to fix it when we're pretty close to it. I'm sure someone else would complain about it in the future.
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

Offline gul

  • Multiple posting newcomer
  • *
  • Posts: 18
Re: Edit shortcuts stopped working !
« Reply #31 on: April 19, 2020, 02:33:30 pm »
Ok i pinpointed the problem. When i installed my OS i setup only ENG layout as default. After install i added SER and SER latin keyboard layouts.

A few weeks ago i wanted to change the default layout to SER, so i moved it up in layout list
(it didn't actualy changed the default just the selection position, to change the default i need to rerun the whole config so i give up and left it like that).

But for some reason when SER is on top, only SER keyboard does work, when ENG is on top everything works correctly. I uploaded screenshot to see what i mean.
(First picture only SER works, second picture everything works)

Unfortunetly i deleted wxWidgest source files, but it was working there yes even when SER was on top, i can test it again if you want.
« Last Edit: April 19, 2020, 02:38:27 pm by gul »

Offline gul

  • Multiple posting newcomer
  • *
  • Posts: 18
Re: Edit shortcuts stopped working !
« Reply #32 on: April 19, 2020, 06:46:48 pm »
Ok, i compiled wxWidgets again, its code is a little different it doesn't have ctrl variable,
 i added the same prinfts except ctrl var, and i got the same numbers,
A is 1792 on ENG layout when Serbian is on top of it in the settings, but everything works unlike in CB.

Code: [Select]
1. KEY: 308 
2. KEY: 308 
4. KEY: 0  RV: 0
1. KEY: 1729 
2. KEY: 1729 
4. KEY: 1729  RV: 0

It doesn't make sense why would position in the layout list change anything other but the actual position?
So I think this is mostly bug in the OS, but because CB handles ctrl differently it shows up only in there.


p.s i just saw that we are actually neighbors, haha
Code: [Select]
Христос Воскресе !

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 12911
    • Travis build status
Re: Edit shortcuts stopped working !
« Reply #33 on: April 19, 2020, 06:54:55 pm »
Ok, I can reproduce this in ubuntu 18.04 in vm...

edit: The fun thing is that adding serbian breaks English. I cannot type ls -l in a terminal any more. It comes out as ls 'l... :)
« Last Edit: April 19, 2020, 07:00:32 pm by oBFusCATed »
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

Offline gul

  • Multiple posting newcomer
  • *
  • Posts: 18
Re: Edit shortcuts stopped working !
« Reply #34 on: April 19, 2020, 07:31:12 pm »
Should I report this to debian/ubuntu/mint community or?

As the for the english break thing, i never experinced that, maybe you ware accidently using serbian latin

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 12911
    • Travis build status
Re: Edit shortcuts stopped working !
« Reply #35 on: April 19, 2020, 07:45:26 pm »
I'm not sure how many bugs I've hit there... :( Why do you have something like 6 or 7 layouts? In Bulgaria we have 3 and they are too many... ;)

About the problem in C::B. I'm able to reproduce the problem in the stc sample, so there is no mystery there.
It is a lot harder, because ctrl-c/v/a are assigned to menu items and are handled by gtk, so they make the impression that shortcuts work, but this is not the case.
If you try ctrl-u/ctrl-shift-u you'll see that they don't work.
The way we do this is by reporting this to wx and waiting for a fix.

I'll try to find the original ticket and I'll post a message there...
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

Offline gul

  • Multiple posting newcomer
  • *
  • Posts: 18
Re: Edit shortcuts stopped working !
« Reply #36 on: April 19, 2020, 11:25:46 pm »
Haha I don't know why they made so many, people mostly use only 2 - cyrilic and latin.

I just found out layout at the top is actually the default layout, now finally everything makes sense to me haha

One more thing,
After i saw that you are from Bulgaria, I wondered who, how and when initially developed C::B,
but i couldn't find that information anywhere about history how C::B was born and the developers etc?