Author Topic: Edit shortcuts stopped working !  (Read 3783 times)

Offline gul

  • Multiple posting newcomer
  • *
  • Posts: 18
Edit shortcuts stopped working !
« on: April 15, 2020, 07:07:55 pm »
Hello everyone,


First of all, since this my first post here, I would like to thank everyone involved for making sure CB is as good as it is. I've been using it for about 8 years on various systems and I had no absolutely issues until now.

Anyway I haven't used CB in about last two months but today I wanted to test out some code I typed previously in plain text editor. When I tried to paste the code using CTRL-V nothing happened, so i tried with rightclick menu - that worked.
 
I restarted both CB and my machine - that did not fix the problem. After that I installed the latest version (20.3) and moved the config folder but that also did not help.

Upon further investigation i discovered that CTRL-C, CTRL-V, CTRL-X and CTRL-A (copy,paste,cut,select all) shortcuts stopped working in CB.

Also i cant change ANY keyboard shortcuts in settings, nothing happens when i press CTRL-* it doesn't register the other key, just CTRL (* is any latter, for some reason numbers and some chars do work)

Interesting thing is that all the shortcuts that do not work are NOT listed in keybind config files (for e.g. CTRL-S saves the file correctly as it should.)
I suppose they are managed by the OS and that's most probably where the problem is but i don't have the knowledge to solve it.


I'm running CB20.3 on Linux Mint 19.3 Cinnamon, the problem occurs only in CB so far.

This is one of the strangest software behaviors I saw, so any help would be appreciated.


Thanks in advance and stay safe.
« Last Edit: April 15, 2020, 07:44:05 pm by gul »

Offline stahta01

  • Lives here!
  • ****
  • Posts: 7017
    • My Best Post
Re: Edit shortcuts stopped working !
« Reply #1 on: April 15, 2020, 07:11:43 pm »
IIRC, the mouse sap plugin might be a possible cause. You could try turning it off.

Also, you might mention the desktop software being used; I have no idea what desktop Cinnamon uses.
I would also mention the wxGTK version information.

Edit: I just found out that Cinnamon is a desktop.

Tim S.

« Last Edit: April 15, 2020, 07:19:56 pm by stahta01 »
C Programmer working to learn more about C++ and Git.
On Windows 7 64 bit and Windows 10 32 bit.
On Debian Stretch, compiling CB Trunk against wxWidgets 3.0.
--
When in doubt, read the CB WiKi FAQ. http://wiki.codeblocks.org

Offline gul

  • Multiple posting newcomer
  • *
  • Posts: 18
Re: Edit shortcuts stopped working !
« Reply #2 on: April 15, 2020, 07:31:47 pm »
Hey thanks for the quick reply,

I just tried to disable mouse sap plugin, that did not solve the problem.

I'm relatively new to linux, so I'm not exactly sure what do you mean, afaik Cinnamon is the desktop software?

Also i'm not sure how to find the wxGTK version?
« Last Edit: April 15, 2020, 07:34:29 pm by gul »

Offline stahta01

  • Lives here!
  • ****
  • Posts: 7017
    • My Best Post
Re: Edit shortcuts stopped working !
« Reply #3 on: April 15, 2020, 07:35:16 pm »
Code::Blocks option:
Help -> About
Tab: Information.

I get this about wxWidgets
Quote
wxWidgets Library (wxMSW port)
Version 3.1.3 (Unicode: wchar_t, debug level: 1),
compiled at Nov  1 2019 18:53:26

I missed this part of the information.
Quote
Runtime version of toolkit used is 6.1.

Tim S.
C Programmer working to learn more about C++ and Git.
On Windows 7 64 bit and Windows 10 32 bit.
On Debian Stretch, compiling CB Trunk against wxWidgets 3.0.
--
When in doubt, read the CB WiKi FAQ. http://wiki.codeblocks.org

Offline gul

  • Multiple posting newcomer
  • *
  • Posts: 18
Re: Edit shortcuts stopped working !
« Reply #4 on: April 15, 2020, 07:55:20 pm »
Code: [Select]
Name             : Code::Blocks
Version          : 20.03-r11983
SDK Version      : 2.0.0
Scintilla Version: 3.7.5
Author           : The Code::Blocks Team
E-mail           : [email protected]
Website          : http://www.codeblocks.org

wxWidgets Library (wxGTK port)
Version 3.0.4 (Unicode: wchar_t, debug level: 1),
Runtime version of toolkit used is 2.24.
Compile-time GTK+ version is 2.24.32.

Offline stahta01

  • Lives here!
  • ****
  • Posts: 7017
    • My Best Post
Re: Edit shortcuts stopped working !
« Reply #5 on: April 15, 2020, 07:59:07 pm »
Thank you for the information; that should hopefully be enough for an Linux person to figure out the problem.

Tim S.
C Programmer working to learn more about C++ and Git.
On Windows 7 64 bit and Windows 10 32 bit.
On Debian Stretch, compiling CB Trunk against wxWidgets 3.0.
--
When in doubt, read the CB WiKi FAQ. http://wiki.codeblocks.org

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 12911
    • Travis build status
Re: Edit shortcuts stopped working !
« Reply #6 on: April 15, 2020, 09:58:56 pm »
Does copy/paste using the menu items work?
What happens if you delete the keybinder config? Or if you disable the plugin?
There were several problems with the plugin which have been fixed, but unfortunately 20.03 didn't get all the fixes.
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

Offline gul

  • Multiple posting newcomer
  • *
  • Posts: 18
Re: Edit shortcuts stopped working !
« Reply #7 on: April 15, 2020, 11:05:21 pm »
Hello,

Copy,paste etc using menu does work.
I already tried to delete codeblocks config folder alltogether that didn't help, if that's what you mean.
When this problem appeared i didn't even had the keyboard shortcuts plugin installed, i installed contrib package later in an effort to fix the problem.
Besides there are NO keybinds for copy,paste,cut, and selectall in the keybind config files BY DEFAULT, i double checked on another machine.
This is most probably beacuse the CB relies on OS to handle them.
Now I tried to disable all plugins to test if that will fix it, but for some reason when i disable ThreadSearch plugin it causes a crash,
even more interesting when i searched for the crash report file "codeblocks.xml" i found it in folder "~$/.wine/dosdevices/z:/tmp"
Why would crash report end up in wine folder?
Everything here to me points to a problem how CB communicates with the OS or vice versa, but I'm not an expert.


Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 12911
    • Travis build status
Re: Edit shortcuts stopped working !
« Reply #8 on: April 15, 2020, 11:57:18 pm »
This is most probably beacuse the CB relies on OS to handle them.
Highly unlikely. C::B relies on code in wx or scintilla to handle these...

Now I tried to disable all plugins to test if that will fix it, but for some reason when i disable ThreadSearch plugin it causes a crash
Known problem, unfortunately I've fixed it after 20.03 shipped.
Leave this plugin loaded or find its dll and delete it.

Everything here to me points to a problem how CB communicates with the OS or vice versa, but I'm not an expert.
I doubt it. The OS is too far away from this code to be related.

Are you saying that this problem happens with both 17.12 and 20.03? Do you have some strange non default software for clipboard or keyboard installed?

What kind of keyboard layout are you running? What is your locale?
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 12911
    • Travis build status
Re: Edit shortcuts stopped working !
« Reply #9 on: April 16, 2020, 09:46:59 am »
Pretty similar sounding problem: https://sourceforge.net/p/codeblocks/tickets/950/
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

Offline gul

  • Multiple posting newcomer
  • *
  • Posts: 18
Re: Edit shortcuts stopped working !
« Reply #10 on: April 16, 2020, 04:19:24 pm »

Are you saying that this problem happens with both 17.12 and 20.03? Do you have some strange non default software for clipboard or keyboard installed?

What kind of keyboard layout are you running? What is your locale?

Yes i have this problem on both versions and no i don't use anything custom for keyboard or clipboard.

I'm from Serbia, but i use mostly ENG keyboard, i tried both just to be sure.
Interesting thing is that i actually changed the OS language from ENG to my native a few weeks ago (haven't used CB in 2 months)
but i tried to switch it back to ENG and that didn't solve the problem.
I also suspect that this might be related but i have no idea how to investigate further in this direction

Pretty similar sounding problem: https://sourceforge.net/p/codeblocks/tickets/950/

It doesn't feel to me like it is, because in my case all the shortcuts in the keybind config work(CTRL-Z, CTRL-S etc), only the ones that are handled separately don't.

I actually found out EXACTLY the same problem as mine posted already but there's no help in that topic:
http://forums.codeblocks.org/index.php/topic,22253.msg151491.html
« Last Edit: April 16, 2020, 04:21:48 pm by gul »

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 12911
    • Travis build status
Re: Edit shortcuts stopped working !
« Reply #11 on: April 16, 2020, 07:28:01 pm »
I don't think this is related to your issue. In the past there was a problem, but it was fixed.

So are you able to reproduce the problem if the keybinder plugin is disabled/removed?
Is ctrl-u/ctrl-shift-u doing something if you have selected text in the editor?
What is the output of "locale -a" and "setxkbmap -query"?
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

Offline gul

  • Multiple posting newcomer
  • *
  • Posts: 18
Re: Edit shortcuts stopped working !
« Reply #12 on: April 17, 2020, 08:58:17 pm »
Yes, keybinder plugin wasn't even installed when i discovered this problem.
I selected some text but CTRL-U, and CTRL-SHIFT-U doesn't do anything.
I even dont know what are tease for, also couldn't find them in keybind config.

locale -a:
Code: [Select]
C
C.UTF-8
en_AG
en_AG.utf8
en_AU.utf8
en_BW.utf8
en_CA.utf8
en_DK.utf8
en_GB.utf8
en_HK.utf8
en_IE.utf8
en_IL
en_IL.utf8
en_IN
en_IN.utf8
en_NG
en_NG.utf8
en_NZ.utf8
en_PH.utf8
en_SG.utf8
en_US.utf8
en_ZA.utf8
en_ZM
en_ZM.utf8
en_ZW.utf8
POSIX
sr_ME
sr_ME.utf8
sr_RS
[email protected]
sr_RS.utf8
[email protected]

setxkbmap -query:
Code: [Select]
rules:      evdev
model:      pc105
layout:     rs,us,rs
variant:    ,,latin
options:    grp:shift_caps_toggle,grp:alt_shift_toggle

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 12911
    • Travis build status
Re: Edit shortcuts stopped working !
« Reply #13 on: April 17, 2020, 09:04:05 pm »
ctrl-u/shift-u make the selected text upper or lower case :)

Uf, I've requested the wrong command... it is just locale not locale -a :(
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 12911
    • Travis build status
Re: Edit shortcuts stopped working !
« Reply #14 on: April 17, 2020, 09:08:50 pm »
One more question:
Does pasting works in text controls?
For example: Can you paste something in Settings -> Environment -> General settings -> Shell to run commands in?

Also are you able to build the software manually. If you're able to paste this might be a clue to the problem...
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]