Author Topic: Using multiple version of wxWidgets with Linux  (Read 147 times)

Offline Pecan

  • Plugin developer
  • Lives here!
  • ****
  • Posts: 2143
Using multiple version of wxWidgets with Linux
« on: June 14, 2019, 08:05:05 pm »
Can multiple versions of wxWidgets reside on Linux Mint?

If so, how can I install wxWidgets v2.8.12 and v3.1.1 on my Linux Mint 17.2 in order to do better validation of plugins. Mint currently contains wxWidgets 3.0 .

 

Online sodev

  • Regular
  • ***
  • Posts: 280
Re: Using multiple version of wxWidgets with Linux
« Reply #1 on: June 14, 2019, 09:07:36 pm »
In general, yes, the tricky part is to select which one is used.

CodeBlocks, at least when building with autotools, uses the wx-config script. Depending on how you install the wxWidgets versions installation source and/or order determine which one will be used by default: the one from /usr/bin or /usr/local/bin and to what real version the symlink points.

The CodeBlocks autotools don't supply the requested version to the wx-config script but you can tell it which script to use. In my case, my selfbuild wx-master installs wx-config into /usr/local/bin which points to /usr/local/lib64/wx/config/gtk3-unicode-3.1. If i want to make sure that CodeBlocks uses this version i would execute ./configure --with-wx-config=/usr/local/lib64/wx/config/gtk3-unicode-3.1

I don't use Linux Mint, i don't know what packages they offer, but you can always compile from source. You might need to figure out which packages you need to install to be able to compile, since it offers wxWidgets 3.0 a good start would be to install the dev-packages of the libraries this package depends on.

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 11783
    • Travis build status
Re: Using multiple version of wxWidgets with Linux
« Reply #2 on: June 14, 2019, 10:07:56 pm »
Build wx manually and specify non-default prefix. Then use --with-wx-config=path-to-wx-config-in-non-default-prefix. This is what I use to test non-default versions of wx.
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]