Author Topic: Compiling Code::Blocks: ./bootstrap command errors.  (Read 3793 times)

Offline Miguel Gimenez

  • Regular
  • ***
  • Posts: 381
Re: Compiling Code::Blocks: ./bootstrap command errors.
« Reply #15 on: August 15, 2019, 02:04:14 pm »
Welcome to Linux where unlike in Windows the current directory is not on the search path.

This is true for cmd.exe, but not for PowerShell. M$ is slowly approaching to Linux.

Offline Krice

  • Almost regular
  • **
  • Posts: 130
Re: Compiling Code::Blocks: ./bootstrap command errors.
« Reply #16 on: August 15, 2019, 04:15:04 pm »
Welcome to Linux where unlike in Windows the current directory is not on the search path.

Could you like stay away from this discussion, because you are not adding anything to it? If you like to insult people, do it elsewhere.

Offline sodev

  • Regular
  • ***
  • Posts: 333
Re: Compiling Code::Blocks: ./bootstrap command errors.
« Reply #17 on: August 15, 2019, 04:29:43 pm »
Should have quoted your following sentence as well... but yes, i already told you two times what the problem is and how to fix it, i am done here.

Offline stahta01

  • Lives here!
  • ****
  • Posts: 6672
    • My Best Post
Re: Compiling Code::Blocks: ./bootstrap command errors.
« Reply #18 on: August 16, 2019, 12:22:03 am »
So, does the clearly obvious code work?

Code: [Select]
export ACLOCAL_FLAGS="-I `./wx-config --prefix`/share/aclocal"

Edit: And, post a link to the wxWidgets directions you are following.

Edit2: And, why does the directions not say to install the wxWidgets?

And, why do you NOT use the wxforums to get help?

Tim S.
« Last Edit: August 16, 2019, 12:53:45 am by stahta01 »
C Programmer working to learn more about C++ and Git.
On Windows 7 64 bit and Windows 10 32 bit.
On Debian Stretch, compiling CB Trunk against wxWidgets 3.0.
--
When in doubt, read the CB WiKi FAQ. http://wiki.codeblocks.org

Offline Krice

  • Almost regular
  • **
  • Posts: 130
Re: Compiling Code::Blocks: ./bootstrap command errors.
« Reply #19 on: August 16, 2019, 02:46:40 pm »
So, does the clearly obvious code work?

It does.. I guess. It's not telling anything. However bootstrap doesn't work, it's still stopping when it doesn't find /Users/Krice/Documents/wxw/share/aclocal directory. That directory doesn't exist, so it's kind of hard to find it.

Quote
Edit: And, post a link to the wxWidgets directions you are following.

docs/osx/install.md in wxwidgets.

Quote
Edit2: And, why does the directions not say to install the wxWidgets?

It does. It IS installed. However there are two kinds of installation, local and to usr/ (system) with sudo make install. The system wide installation is not recommended in docs/osx/install.md so I haven't done it yet. The question is does Code::Blocks require it?

Quote
And, why do you NOT use the wxforums to get help?

I have. wxWidgets installation works, no problems there.

Offline sodev

  • Regular
  • ***
  • Posts: 333
Re: Compiling Code::Blocks: ./bootstrap command errors.
« Reply #20 on: August 16, 2019, 06:26:04 pm »
It IS installed.

It is NOT installed. If it would be installed, /Users/Krice/Documents/wxw/share/aclocal would exist, because your prefix is /Users/Krice/Documents/wxw so a make install would install into that prefix and during installation share/aclocal would be created to put wxwin.m4 into it.

Offline stahta01

  • Lives here!
  • ****
  • Posts: 6672
    • My Best Post
Re: Compiling Code::Blocks: ./bootstrap command errors.
« Reply #21 on: August 16, 2019, 09:32:31 pm »
Krice: I never liked the twenty question game; I will add you to my list of people who it is useless to try to help!!

You skipped the installation step; but, you keep saying you installed wxWidgets!!!!!!!!!!

Tim S.
C Programmer working to learn more about C++ and Git.
On Windows 7 64 bit and Windows 10 32 bit.
On Debian Stretch, compiling CB Trunk against wxWidgets 3.0.
--
When in doubt, read the CB WiKi FAQ. http://wiki.codeblocks.org

Offline Krice

  • Almost regular
  • **
  • Posts: 130
Re: Compiling Code::Blocks: ./bootstrap command errors.
« Reply #22 on: August 18, 2019, 10:26:18 am »
It is NOT installed.

I ran sudo make install and now ./bootstrap work, however when I run ./configure for Code::Blocks I get this error:

Code: [Select]
configure: error: Package requirements (hunspell) were not met:

No package 'hunspell' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables HUNSPELL_CFLAGS
and HUNSPELL_LIBS to avoid the need to call pkg-config.

By the way, wxwidget people say Code::Blocks is doing it the wrong way, you should not have to make install the library:
https://forums.wxwidgets.org/viewtopic.php?f=23&p=193484&sid=2001ebb0b423d41e4be8134b3ef2758d#p193484

Offline stahta01

  • Lives here!
  • ****
  • Posts: 6672
    • My Best Post
Re: Compiling Code::Blocks: ./bootstrap command errors.
« Reply #23 on: August 18, 2019, 02:41:03 pm »
You have a lot to learn about programming.

I hope you have a sane reason to self build Code::Blocks.

Tim S.
C Programmer working to learn more about C++ and Git.
On Windows 7 64 bit and Windows 10 32 bit.
On Debian Stretch, compiling CB Trunk against wxWidgets 3.0.
--
When in doubt, read the CB WiKi FAQ. http://wiki.codeblocks.org

Offline Krice

  • Almost regular
  • **
  • Posts: 130
Re: Compiling Code::Blocks: ./bootstrap command errors.
« Reply #24 on: August 19, 2019, 08:47:05 am »
You have a lot to learn about programming.

No, I only need to "learn" the idiocy that is unix command line "programming". In Windows this problem doesn't even exist, because projects are created in IDE (as they should) and libraries are mostly pre-compiled and ready to use. Compiling everything from source seems to be somewhat problematic to say the least, but it's something you need when nothing stays compatible and there are different versions of everything. Even OSX can break programs when they release a new os version.

Offline BlueHazzard

  • Developer
  • Lives here!
  • *****
  • Posts: 2566
Re: Compiling Code::Blocks: ./bootstrap command errors.
« Reply #25 on: August 19, 2019, 11:00:53 am »
About hunspell... well you have to install the dev package of hunspell or configure codeblocks without spellchecker.
About installing wxWidgets: How should it be? Where should codeblocks look for wx installations, if not in the global folder. I have read your forum link, but i can not find out how it should be done right...
I do nothing with the autotools scrips and the AM system, so i may be wrong hardly, but isn't it that the bootstrap searches for wxWidgets AM scripts, that tell the autotools process where to search wxWidgets and what configuration to use? So if the AM scripts are not found in the right place (by being installed in the global install directory) how should bootstrap continue? Or in what directories should bootstrap search for AM files?

Offline Krice

  • Almost regular
  • **
  • Posts: 130
Re: Compiling Code::Blocks: ./bootstrap command errors.
« Reply #26 on: August 19, 2019, 12:25:48 pm »
About hunspell... well you have to install the dev package of hunspell

I think it would be nice to inform that you need some external packages and how to get them. In this case 'brew install hunspell' fixed this problem, although it gives an error since it can't write something to usr/local... but Code::Blocks ./configure works so it's probably not important. At the moment I'm building C::B with make. It's running in background so I'll get back if something fails.

Offline BlueHazzard

  • Developer
  • Lives here!
  • *****
  • Posts: 2566
Re: Compiling Code::Blocks: ./bootstrap command errors.
« Reply #27 on: August 19, 2019, 01:59:31 pm »
It would be really really great if you could write up your findings, and post it in the wiki (the forum user name should be the same for the wiki) Or write it up here and i will move it to the wiki... Some easy step by step guide would be nice...

As i told earlier, we do not have many (actually none) mac devs and every bit of information helps....

Thank you!

Offline Krice

  • Almost regular
  • **
  • Posts: 130
Re: Compiling Code::Blocks: ./bootstrap command errors.
« Reply #28 on: August 19, 2019, 02:57:46 pm »
It would be really really great if you could write up your findings

I can try to write something later (I have kept a blog about unix programming, but it's a mess). Meanwhile it did build and also runs. The readme is talking about 'devel' and 'output' directories but afaik no such things exist. It's creating codeblocks executable in usr/local/bin and that's about it. When you exit codeblocks it throws this:

Deinitializing plugins...
../src/osx/window_osx.cpp(727): assert ""tlw"" failed in DoClientToScreen(): TopLevel window missing
Collecting stack trace information, please wait...Trace/BPT trap: 5

But I'm not that surprised. I tried to run cppcheck for couple of files and already got warnings. It's really not that difficult to fix those kind of problems with cppcheck or some other static analysis tool like heavier use of gcc compiler flags. Cppcheck is a tool everyone should use in C++ programming in my opinion, it's just so easy to catch typical stuff with it.

Offline BlueHazzard

  • Developer
  • Lives here!
  • *****
  • Posts: 2566
Re: Compiling Code::Blocks: ./bootstrap command errors.
« Reply #29 on: August 19, 2019, 04:19:38 pm »
Every report helps... And patches help even more...
Thank you in advance!