Author Topic: Code linting in code::blocks (specificly C++)  (Read 545 times)

Offline codedcosmos

  • Single posting newcomer
  • *
  • Posts: 3
Code linting in code::blocks (specificly C++)
« on: October 02, 2018, 11:04:15 am »
It has been over a decade since:
http://forums.codeblocks.org/index.php?topic=7590.0l

Speaking of which congrats for keeping the project alive for that long.

Is linting possible in code blocks?

This (unverifiable) page says you can:
https://www.quora.com/Which-IDE-except-Eclipse-shows-syntax-error-while-writing-C%2B%2B-codes

Offline BlueHazzard

  • Developer
  • Lives here!
  • *****
  • Posts: 2092
Re: Code linting in code::blocks (specificly C++)
« Reply #1 on: October 02, 2018, 03:46:34 pm »
What do you understand by code linting?
Higlightening wrong code in the ide? If this-> There is the cbClang plugin that allows this. But you have to build the plugin by yourself. https://github.com/yvesdm3000/ClangLib
Run some code analyzer on top of your code? If this-> What program?

Offline BlueHazzard

  • Developer
  • Lives here!
  • *****
  • Posts: 2092
Re: Code linting in code::blocks (specificly C++)
« Reply #2 on: October 02, 2018, 03:51:52 pm »
If you are talking about this:
https://docs.oracle.com/cd/E19205-01/820-4180/man1/lint.1.html

Can you give some example command line you call for lint?

Offline codedcosmos

  • Single posting newcomer
  • *
  • Posts: 3
Re: Code linting in code::blocks (specificly C++)
« Reply #3 on: October 12, 2018, 06:00:12 am »
Sorry for late reply, not sure about elsewhere but the fourms have been down semi regularly for me.

Not sure about a specific command, but something similar to what eclipse or visual studio ide does. something like the red lines below text that has a compiling issue.

Offline codedcosmos

  • Single posting newcomer
  • *
  • Posts: 3
Re: Code linting in code::blocks (specificly C++)
« Reply #4 on: October 12, 2018, 06:06:03 am »
When I type complete gibberish, no real time linting occurs, its only until after I build that a red box appears, but even then, no description is provided, I have to manually check "build messages".