Author Topic: [Resolved] Resource Compiler fails without any helpful output  (Read 851 times)

Offline Frank_CB

  • Single posting newcomer
  • *
  • Posts: 9
Hello,

I installed CB 17.12 32-bit binaries on a Windows 10 platform in 03/2018. On 05/2018, I installed a nightly build of CB 17.12, which consists of 64-bit binaries.  I integrated Microsoft's C15++ Toolkit (which contains Compilers, Linkers and Resource Compilers) into both.

I have been able to build both debug and release versions of a Microsoft Foundations Classes project with Microsoft Visual Studio 2017 Community without any trouble. However, both versions of CB stopped while compiling the project's resources with the resource compiler, after compiling the first two C++ programs.
CB just stopped processing the project after saying the resource compiler failed (no other information).

I've been able to compile all the project's C++ programs and resources outside of both versions of CB's IDE.  Looking through the options of CB, I haven't been able to find anything that affects the resource compiler.

Any suggestions that might help me setup CB, so that the resource compiler plays well in the IDE, would really be appreciated. I've looked on the internet and in CB's forums without any success.

Regards! 





















   
« Last Edit: July 31, 2018, 07:05:08 pm by Frank_CB »

Offline stahta01

  • Lives here!
  • ****
  • Posts: 6310
    • My Best Post
Re: Resource Compiler fails without any helpful output
« Reply #1 on: June 29, 2018, 05:44:58 am »
Post the full build log!

Tim S.
C Programmer working to learn more about C++ and Git.
On Windows 7 64 bit and Windows 10 32 bit.
On Debian Testing, compiling CB Trunk against wxWidgets 3.0.2.
--
When in doubt, read the CB WiKi FAQ. http://wiki.codeblocks.org

Offline Frank_CB

  • Single posting newcomer
  • *
  • Posts: 9
Re: Resource Compiler fails without any helpful output
« Reply #2 on: June 29, 2018, 05:38:48 pm »
Tim, Here are the build logs from the 64 bit version of CB :'(

Offline stahta01

  • Lives here!
  • ****
  • Posts: 6310
    • My Best Post
Re: Resource Compiler fails without any helpful output
« Reply #3 on: June 29, 2018, 06:09:08 pm »
Code: [Select]
rc.exe /I. /IDebug\ /I"C:\Program Files (x86)\Windows Kits\10\Include\10.0.17134.0\shared" /I"C:\Program Files (x86)\Windows Kits\10\Include\10.0.17134.0\ucrt" /I"C:\Program Files (x86)\Windows Kits\10\Include\10.0.17134.0\um" /I"C:\Program Files (x86)\Microsoft Visual Studio\2017\BuildTools\VC\Tools\MSVC\14.14.26428\include" /I"C:\Program Files (x86)\Microsoft Visual Studio\2017\BuildTools\VC\Tools\MSVC\14.14.26428\atlmfc\include" /v  /foDebug\Ex1_03.res Ex1_03.rc

The only think I wonder about is
Code: [Select]
/IDebug\

The backslash seems wrong; I will try whatever MS Compiler is on my machine in the next few days to see what it should look like.
I think it is 2015 Community edition.

You might try the 32 bit version of Code::Blocks to make sure it is not a 64 bit CB issue.
C Programmer working to learn more about C++ and Git.
On Windows 7 64 bit and Windows 10 32 bit.
On Debian Testing, compiling CB Trunk against wxWidgets 3.0.2.
--
When in doubt, read the CB WiKi FAQ. http://wiki.codeblocks.org

Offline Frank_CB

  • Single posting newcomer
  • *
  • Posts: 9
Re: Resource Compiler fails without any helpful output
« Reply #4 on: June 30, 2018, 04:03:23 am »
@Stahta01
Thanks for replying!

I removed both 'Debug\' and 'Release\' from the build options of the project. Both target builds still failed.  I removed them from my scripts that use the compilers outside of the IDE and all programs compiled successfully.  I'm still working on linking all of the obj files together outside of CB's IDE.

I'm including all the source code for the mfc project in a zip file. I believe it used both C10++ and MSVS2010.

Regards


Offline BlueHazzard

  • Lives here!
  • ****
  • Posts: 2022
Re: Resource Compiler fails without any helpful output
« Reply #5 on: June 30, 2018, 12:04:50 pm »
can you also post teh log of a successful build in console? And the according command line?

Offline Frank_CB

  • Single posting newcomer
  • *
  • Posts: 9
Re: Resource Compiler fails without any helpful output
« Reply #6 on: July 02, 2018, 09:21:45 pm »
@BlueHazzard

The two items that you asked for are attached:

CBBuild.txt is the build log from CB that failed. The .rc file is the third file in list of input files. The project has no dependencies.

CommandLineBuild.txt shows the command lines for all six .cpp files that build successfully outside of the IDE.

I'm also able to create .res files, then .obj files, outside of the IDE.  Currently working on linking the appropriate .obj files together into .exe files outside of the IDE.

Regards

Offline Frank_CB

  • Single posting newcomer
  • *
  • Posts: 9
Re: [Resolved] Resource Compiler fails without any helpful output
« Reply #7 on: August 12, 2018, 07:15:55 pm »
Hello,

I probably should explain what my solution for this problem was.

The Resource Compiler could handle the resources outside of the IDE, but it failed inside.  The problem turned out to be that I had not included the resources directory in the Include Directories for the Resource Compiler inside the IDE.  Adding that directory solved that problem.

Regards

Frank

Offline BlueHazzard

  • Lives here!
  • ****
  • Posts: 2022
Re: [Resolved] Resource Compiler fails without any helpful output
« Reply #8 on: August 12, 2018, 11:22:33 pm »
Thank you for posting a solution! This will help others!