Author Topic: Default Compiler doesn't ever work?  (Read 4320 times)

Offline Bitpower

  • Single posting newcomer
  • *
  • Posts: 6
Default Compiler doesn't ever work?
« on: January 25, 2006, 02:51:44 pm »
I've been trying to set my "default compiler" to Open Watcom. 

I have four different free compilers installed and correctly setup under Code Blocks and do NOT have gcc installed.    All the free compilers that I have installed are compilers that are supported by Code Blocks:  ( borland freecommandlinetools (borland c++ 5.5), ms visual toolkit 2003, open watcom, and digital mars).     And I can manually switch from one compiler to another for compiling.

I'm 100% sure that Open Watcom is set as my default compiler in the "compiler options".   I have went to the settings / compiler menu and set it as the default over a 100 times.  So I'm sure.  Actually I tryed setting multiple different compilers as the default.  And no matter which compiler I setup as default, it always totally and completely ignores it, and always goes to GCC as the default.

Everytime I create a new project, it always defaults to GCC.   When I go to the project / build options menu, it always has GCC as the default compiler.  Even though GCC isn't even installed. 

So can anyone tell me how to "force" the software to use Open Watcom as my default compiler?  So when I click on new project, and start a new project, it automatically uses Open Watcom?   

Offline Michael

  • Lives here!
  • ****
  • Posts: 1608
Re: Default Compiler doesn't ever work?
« Reply #1 on: January 25, 2006, 02:58:46 pm »
Hello,

Which C::B version are you using? If RC2, please try with a nightly build or build C::B from the SVN sources.

Best wishes,
Michael

Offline Bitpower

  • Single posting newcomer
  • *
  • Posts: 6
Re: Default Compiler doesn't ever work?
« Reply #2 on: January 25, 2006, 06:53:27 pm »
I just got the software yesterday.   So its the newest version. 

Offline Michael

  • Lives here!
  • ****
  • Posts: 1608
Re: Default Compiler doesn't ever work?
« Reply #3 on: January 25, 2006, 07:10:52 pm »
I just got the software yesterday.   So its the newest version. 

Well, C::B devs work not only very good, but also very fast :D. Each day there are several new revisions :D. Each day I compile C::B at least 2-3 times.

I have no problems with the compiler. If I create a project that use M$ toolkit 2003, each time I open it, the compiler is set to M$ toolkit 2003. Tested with C::B rev1859 and 1861.

Michael
« Last Edit: January 25, 2006, 07:15:38 pm by Michael »

Offline mandrav

  • Project Leader
  • Administrator
  • Lives here!
  • *****
  • Posts: 4291
    • Code::Blocks IDE
Re: Default Compiler doesn't ever work?
« Reply #4 on: January 25, 2006, 08:00:21 pm »
I just got the software yesterday.   So its the newest version. 

And now this is supposed to tell us the exact version you 're using?
For all I know, you may have downloaded 1.0rc1 just yesterday. Except that it's 6 months old...
Be patient!
This bug will be fixed soon...

Offline Bitpower

  • Single posting newcomer
  • *
  • Posts: 6
Re: Default Compiler doesn't ever work?
« Reply #5 on: January 25, 2006, 08:16:13 pm »
I went to the site  http://www.codeblocks.org/

On the homepage it says:
Code::Blocks
The open source, cross platform Free C++ IDE.
Newest version: 1.0rc2, Oct 25, 2005

I had clicked on the link to download the newest version.  So the version I got was 1.0rc2, october 25, 2005.  I guess that is the newest "released" version. 

I presume what you guys are talking about with "nightly" builds is what currently is under development.

Where do you download the nightly builds?   And are they already compiled into binary, or do you need to compile them yourself?  I don't have the compiler software I downloaded setup well enough to compile large projects yet.  So hopefully this nightly build thing is in binary format?   Could you let me know.





sethjackson

  • Guest
Re: Default Compiler doesn't ever work?
« Reply #6 on: January 25, 2006, 08:19:14 pm »
Nightly build board. :)

http://forums.codeblocks.org/index.php?board=20.0

EDIT:

They are already compiled. :) You need 7-Zip to decompress them.

http://7-zip.org/

Offline bitcero

  • Single posting newcomer
  • *
  • Posts: 7
Re: Default Compiler doesn't ever work?
« Reply #7 on: February 02, 2006, 03:57:45 pm »
I got the same problem, when i download C::B 1.0rc2.
with 1.0rc1 the default compiler selected is used with the new projects with no problems i think this is a bug in the rc2