Author Topic: Taking into account C99 standard  (Read 26264 times)

Offline Pavel_47

  • Multiple posting newcomer
  • *
  • Posts: 66
Re: Taking into account C99 standard
« Reply #30 on: January 23, 2015, 01:57:53 pm »
Thanks a lot BlueHazzard

Here is project file (with custom makefile)

Offline BlueHazzard

  • Developer
  • Lives here!
  • *****
  • Posts: 2861
Re: Taking into account C99 standard
« Reply #31 on: January 23, 2015, 02:12:11 pm »
With this project you are clearly using a "custom makefile" so you can't use any compiler and build stuff from within c::b.
As far as i know all changes regarding the build process (like adding libraries, or files, add defines) have to be made in the make file. Even the source tree is not take into account (so if you add a .cpp file to the project you have also to add it manually in the make file so it can be build). You have to make ALL on your own in the makefile.

With this process i can't help you. If you go with the custom makefile this is also the wrong forum to ask. You will get more help on the contiki forum. (You have to say that you are using make files, and not the c::b build process, because else they send you back to us ;) )

As far as i can tell the command line to the make process is called correct, as you specified, so this is no c::b bug, but how you write the TARGET variable. ( i have no idea how you have to specify it that it is right, and i also have not the time to look into it, but i can tell you that the cmd line to make is called as you write it in Project->Build Options->Make Commands)

greetings

Offline stahta01

  • Lives here!
  • ****
  • Posts: 7056
    • My Best Post
Re: Taking into account C99 standard
« Reply #32 on: January 25, 2015, 06:34:54 pm »
With this project you are clearly using a "custom makefile" so you can't use any compiler and build stuff from within c::b.
As far as i know all changes regarding the build process (like adding libraries, or files, add defines) have to be made in the make file. Even the source tree is not take into account (so if you add a .cpp file to the project you have also to add it manually in the make file so it can be build). You have to make ALL on your own in the makefile.

With this process i can't help you. If you go with the custom makefile this is also the wrong forum to ask. You will get more help on the contiki forum. (You have to say that you are using make files, and not the c::b build process, because else they send you back to us ;) )

As far as i can tell the command line to the make process is called correct, as you specified, so this is no c::b bug, but how you write the TARGET variable. ( i have no idea how you have to specify it that it is right, and i also have not the time to look into it, but i can tell you that the cmd line to make is called as you write it in Project->Build Options->Make Commands)

greetings

I gave that info in the other thread and he decided in that thread to NOT use a custom make file project.

In a few weeks, I might try to see if there is a real problem doing this; but, I do NOT have the time to try it now for someone who seems to be NOT worth the effort to help. Since, I am likely one of the few people who uses custom make file projects on a regular basis and also a longtime CB poster.

Tim S.
C Programmer working to learn more about C++ and Git.
On Windows 7 64 bit and Windows 10 32 bit.
On Debian Stretch, compiling CB Trunk against wxWidgets 3.0.
--
When in doubt, read the CB WiKi FAQ. http://wiki.codeblocks.org

Offline Pavel_47

  • Multiple posting newcomer
  • *
  • Posts: 66
Re: Taking into account C99 standard
« Reply #33 on: January 25, 2015, 07:05:56 pm »
... but, I do NOT have the time to try it now for someone who seems to be NOT worth the effort to help. Since, I am likely one of the few people who uses custom make file projects on a regular basis and also a longtime CB poster.

Tim S.

The GREATEST in the WORLD EXPERT in Code::Blocks, custom makefiles, ets. !!!
Sorry for having troubled you. Thanks a lot for your inestimable support.
Henceworth don't trouble yourself to answer to my questions !!!