Author Topic: GDB: Failed to set controlling terminal  (Read 12724 times)

Offline nomwise

  • Single posting newcomer
  • *
  • Posts: 2
GDB: Failed to set controlling terminal
« on: March 22, 2011, 11:12:21 am »
Hi!

I have a problem with codeblocks when i wants to debug my program in C++.

I have a mistake which you can see in the attached image



In the bashrc archive, i have two variables calls EM_PREFIX and AMP_PREFIX which are actived
when i open the terminal. When i do "echo $EM_PREFIX or "echo $AMP_PREFIX" in the terminal, i see
that this variables to point at the right route.

When I go to debug my program, i have opened the terminal to these variables are active.

Do you have any idea to solve the mistake?

I use:
- Codeblocks 8.02
- GNU gdb (GDB) 7.1-ubuntu
- Kubuntu 10.04

Thanks and Regards.
Sergio.
« Last Edit: March 22, 2011, 11:24:30 am by nomwise »

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 12224
    • Travis build status
Re: GDB: Failed to set controlling terminal
« Reply #1 on: March 22, 2011, 01:28:45 pm »
Search on the net about the GDB warning and you'll see it is not fatal.

In regard to the rest of you post I don't understand what is your problem, can you describe it in more details.

p.s. Don't use localized GDB or GCC, it could break C::B, because it tries to parse their output
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

Offline nomwise

  • Single posting newcomer
  • *
  • Posts: 2
Re: GDB: Failed to set controlling terminal
« Reply #2 on: March 22, 2011, 02:09:56 pm »
Search on the net about the GDB warning and you'll see it is not fatal.

I have searched this problem on the net but the only thing I have found is this:
"please try to use output window (Project properties-> Run->Console type)"

In my CodeBlocks, i can not find the option to change the "Console type". Where is it?

In regard to the rest of you post I don't understand what is your problem, can you describe it in more details.

In my bashrc archive, I have created one variables calls EM_PREFIX:
export EM_PREFIX=~/Repo/trunk/src/em/share/em

My problem is that codeblocks or gdb does not recognize this variable or i think so. How could i fix it?

p.s. Don't use localized GDB or GCC, it could break C::B, because it tries to parse their output

Then, what compiler must i use?

Thanks for all!

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 12224
    • Travis build status
Re: GDB: Failed to set controlling terminal
« Reply #3 on: March 22, 2011, 03:45:15 pm »
In my CodeBlocks, i can not find the option to change the "Console type". Where is it?
Project-> Properties -> Build Target -> Type -> Console, but if you see the GDB warning your app is console, already.

In my bashrc archive, I have created one variables calls EM_PREFIX:
export EM_PREFIX=~/Repo/trunk/src/em/share/em

My problem is that codeblocks or gdb does not recognize this variable or i think so. How could i fix it?
Why should C::B or GDB know about one random env variable?

Then, what compiler must i use?
Non localized one, it is a settings thing, read about locales and how to set them properly...
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]