Author Topic: When I double click the debug which is next toC/C++ ,the*. exe is flashed past!  (Read 3702 times)

Offline jianlina

  • Single posting newcomer
  • *
  • Posts: 4
 :cry:When I double click the debug which  is next to C/C++ ,the*. exe is flashed past quickly!
What should I do?
(My English is very poor.I wish you could understand me!)
« Last Edit: March 20, 2011, 03:56:16 pm by jianlina »

Offline jens

  • Administrator
  • Lives here!
  • *****
  • Posts: 7253
    • Jens' unofficial debian-repository for the Code::Blocks - IDE
:cry:When I double click the debug which  is next to C/C++ ,the*. exe is flashed past quickly!
What should I do?
(My English is very poor.I wish you could understand me!)
Sorry I do not understand anything and your post misses a lot of information:
Which version of C::B do you use ?
Which OS are you on?
Which compiler do you use ?

Where do you double-click ?
What do you mean with "the debug" ?
What do you mean with "flash[...] past quickly" ?


Offline jianlina

  • Single posting newcomer
  • *
  • Posts: 4
I use Code::Blocks10.05 on windows7.
I use the C language to programme.
When I debug the code there is a question .
You can click "Debug→Start" on the menu of C::B. It build a *. exe  file.
But the *. exe file flashes across quickly.
How can I make it stay?
Thank you very much!
« Last Edit: March 21, 2011, 02:57:33 am by jianlina »

Offline jianlina

  • Single posting newcomer
  • *
  • Posts: 4
 :(   Is there anyone to help me ?
  Thanks...

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 12831
    • Travis build status
Have you tried to put a breakpoint at the line "return 1;" in the main function?
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

Offline jianlina

  • Single posting newcomer
  • *
  • Posts: 4
Must I put a breakpoint at one of the line in the code? If I do not add any breakpoint , can I make the *.exe file stay like that I click "run" on the menu.
When I put a breakpoint  at one of the line in the code ,  then I click 'debug→start' on the menu , the *.exe file appears and minimizes quickly and automatically . How can I solve  the problem?
Thanks...

Offline ptDev

  • Almost regular
  • **
  • Posts: 222
Does the compiled executable actually have debugging information? Check in the project build options whether you inadvertently checked "Strip all symbols information" (or something similar). If this option is checked at project level (rather than just at "Release" target level), you're trying to debug an executable that has no symbols table for gdb to track down.

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 12831
    • Travis build status
Must I put a breakpoint at one of the line in the code?
You must... or you could execute getchar() before the "return 1;" line
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]