Author Topic: SDK version mismatch  (Read 13086 times)

Offline dmoore

  • Developer
  • Lives here!
  • *****
  • Posts: 1576
Re: SDK version mismatch
« Reply #15 on: February 06, 2011, 09:23:04 am »
Also need to take care of this request: http://forums.codeblocks.org/index.php/topic,13217.msg89462.html#msg89462

I won't be able to get to that until later in the week at earliest.

Offline ewww

  • Multiple posting newcomer
  • *
  • Posts: 15
Re: SDK version mismatch
« Reply #16 on: March 16, 2011, 09:57:05 am »
Hi

I am looking into adding features to the dbGcov plugin. Im using the nightly build 7040, the dbg branch, and so have checked out same revision of cb src. The plugin fails to load with:

SDK version mismatch for FileManager (1.11.13). Expecting 1.12.0

What is going on here? I have expected that having the same revision of source as  the nightly should not give any problems whatsoever, but it seems the sdk version is newer.

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 12810
    • Travis build status
Re: SDK version mismatch
« Reply #17 on: March 16, 2011, 10:45:01 am »
You Filemanager plugin is old or build for the normal nightly.
The SDK in the debugger's branch is vastly different. And we've change the versions to mark it.

But this doesn't concern the dbGcov plugin...
If you want to build an external plugin for a nightly you have to build the whole C::B from source,
because the nightlies don't have the SDK included. (this is for windows).
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

Offline jens

  • Administrator
  • Lives here!
  • *****
  • Posts: 7253
    • Jens' unofficial debian-repository for the Code::Blocks - IDE
Re: SDK version mismatch
« Reply #18 on: March 16, 2011, 11:06:33 am »
FileManager is part of the svn sources now.
So if you use a self-build C::B, make sure you do not have an old version in any of the plugin search directories (see "Code::Blocks"-tab in "Logs & others" and look for "Scanning for plugins in ...").

Offline ewww

  • Multiple posting newcomer
  • *
  • Posts: 15
Re: SDK version mismatch
« Reply #19 on: March 16, 2011, 11:09:00 am »
Ok, thanks, that its. I have built cb from the main branch, but was trying to get the plugin loaded by the dbg branch nightly. I didnt take this into consideration before i was actually posting here. No matter what nightly you have, it still prints only the revision number as its version and that confused me.