Author Topic: Another unicode issue  (Read 2130 times)

Offline goblin++

  • Single posting newcomer
  • *
  • Posts: 4
Another unicode issue
« on: May 09, 2010, 08:14:10 am »
hi, i see that there are a lot of unicode/ansi issues around here but i didn't notice someone with a similar problem to mine(excuse me if there is another topic however, i did a search)
so, when i try to open a txt file that uses unicode, this does not happen and no file is opened
i figured out how ot type special unicode chars in the console and get printed ones too but i really need to open unicode txt-s

Offline jens

  • Administrator
  • Lives here!
  • *****
  • Posts: 7255
Re: Another unicode issue
« Reply #1 on: May 09, 2010, 08:21:00 am »
Your post lacks the basic of any question, if you really want an answer:

which version of C::B,
which OS (and version),
if self-compiled, which version of wxWidgets and which compiler and version
do you use ?

Offline goblin++

  • Single posting newcomer
  • *
  • Posts: 4
Re: Another unicode issue
« Reply #2 on: May 09, 2010, 08:28:01 am »
c::b 8.02 (latest) bundled with mingw/gcc
windows XP
i have not explicitly installed wxwidgets

Offline jens

  • Administrator
  • Lives here!
  • *****
  • Posts: 7255
Re: Another unicode issue
« Reply #3 on: May 09, 2010, 08:44:52 am »
c::b 8.02 (latest) bundled with mingw/gcc
windows XP
i have not explicitly installed wxwidgets

In this case you should either try a nighly-builf or wait for the next release, what comes soon.
The encoding-detection has changed (and improved) since 8.02 (even if a pure unicode-file was detected correctly in the most cases).

You can send a test file, where detection fails, to  "chardet at jenslody dot de", so I can see whether it gets detected correctly with the newer C::B.

Offline goblin++

  • Single posting newcomer
  • *
  • Posts: 4
Re: Another unicode issue
« Reply #4 on: May 09, 2010, 09:08:46 am »
done.